Follow

Barbarian (Gamespy Edition) - Do I need to patch Rome: Total War before installing Barbarian Invasion?

You do not need to patch Rome: Total War before installing Barbarian Invasion.

The Barbarian Invasion installer will automatically patch Rome: Total War to the latest version 1.3.

Note that once Barbarian Invasion is installed, you should not install any Rome: Total War patches or the game will cease to work.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk