Follow

iOS – Getting Started

See the full list here: http://www.footballmanager.com/games/football-manager-touch-2016#compatibility

You must have a minimum of iOS 8.0 to run Football Manager Touch 2016.

Approximately 3GB. Your device may require extra space during the download and install process.

Please create a new thread on our bugs forum http://community.sigames.com/forumdisplay.php/529 and we’ll do our best to talk you through resolving any problems you might be having with installing the game.

Such issues are rare, however they’re often device specific so we may need to ask you a few questions in order to resolve them.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk